This Blog

Syndication

Search

Tags

Community

Email Notifications

Archives

Enlaces Recomendados

SharePoint 2013: Instalación de SharePoint Foundation paso a paso!

Puestos a probar una instalación rápida de SharePoint 2013, y como os había comentado en el post de instalación de SharePoint Server 2013, había optado por comenzar con SharePoint Foundation que en este caso he instalado en una máquina virtual creada en Azure y usando Windows Server 2012 RC como S.O de base. Como os comenté en ese primer post, el proceso de instalación es similar al de SharePoint 2010, con una pequeña diferencia: primero tenemos que instalar los pre-requisitos que tienen un instalador independiente y luego podremos proceder a instalar Foundation. Empecemos:

  • Como comentaba, en primer lugar ejecutaremos el asistente para instalar los pre-requisitos.
  • La primera pantalla nos muestra cuáles son los pre-requisitos a instalar:
    • Microsoft .NET Framework 4.0Windows Management Framework 3.0 (CTP2)
    • Rol Servidor de aplicaciones, Rol Servidor web (IIS)
    • Microsoft SQL Server 2008 R2 SP1 Native Client
    • Microsoft Sync Framework Runtime v1.0 SP1 (x64)
    • Windows Server AppFabric
    • Extensiones de Microsoft Identity
    • Microsoft Information Protection and Control Client
    • Microsoft WCF Data Services 5.0
    • Paquete de actualización acumulativa 1 de Microsoft AppFabric 1.1 para Windows Server (KB2671763)
  • En la siguiente pantalla aceptamos el correspondiente acuerdo de licencia y pulsamos Next de nuevo.
image image image
  • A continuación se inicia el proceso de instalación y configuración de los pre-requisitos.
  • Una vez concluye la instalación, es necesario re-iniciar (igual que en SharePoint 2010).
  • Una vez se completa el re-inicio, el asistente de configuración realiza las últimas configuraciones tras las cuales podemos proceder a instalar SharePoint Foundation. Si todo ha ido bien, se mostrará un pantalla indicando que la instalación se ha completado (Nota: En este punto he tenido que re-iniciar de nuevo el equipo).
image image image
  • Tras iniciar el asistente de instalación, como siempre este comprueba que los requisitos estén instalados y configurados y si todo está correcto nos muestra la pantalla de aceptación de licencia correspondiente.
  • Dejamos marcada la opción de instalación de tipo Independiente (nos instala SQL Server 2008 R2 Express SP1 como motor de BD).
  • Tras pulsar continuar, se inicia el proceso de instalación.
image image image
  • Finalizada la instalación, se muestra la pantalla para poder iniciar el asistente de configuración. Si pulsamos el botón “Close”, lanzaremos el configurador…pero no lo haremos, puesto que como os comentaba ayer, el proceso falla y no por la versión de Windows Server, sino por el proceso en sí…ayer como fue un día de locos, no me paré detenidamente a ver que pasaba e indagar en el problema…esta mañana que he he llegado un poco más fresco si lo he hecho, y rápidamente he encontrado como solucionarlo tal y como se describe aquí: http://tomblog.insomniacminds.com/2012/07/17/sharepoint-2013-standalone-installation-issue/comment-page-1/#comment-80831. Vamos, que en el lugar de ejecutar el asistente de configuración de forma convencional lo ejecutemos vía interfaz de línea de comandos para podernos saltar el paso que está dando el problema y qué no es otro que la configuración y registro del AppFabric que por algún motivo no se está haciendo de forma correcta para una instalación de tipo independiente:
   1: PS C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\BIN>.\PSCONFIG.EXE -cmd Configdb create SkipRegisterAsDistributedCacheHost
  • Por lo tanto, antes de ejecutar la línea anterior lo que hacemos es desmarcar la opción de ejecutar el asistente de configuración y pulsamos el botón “Cerrar”.
  • Abrimos la consola de administración de SharePoint 2013 para proceder a ejecutar el asistente de configuración con la opción comentada y cruzamos los dedos para que haga las configuraciones necesarias como crear correctamente la BD de configuración.
  • Si todo va bien, deberíamos visualizar por pantalla que la BD de configuración se ha creado de forma correcta.
image image image
  • Siguiendo con el workaround, lo siguiente que haremos es ejecutar de nuevo el asistente de configuración usando la interfaz visual.
  • Pulsamos “Siguiente” en la primera ventana y a continuación “Yes” en el conocido mensaje de warning…y ahora a rezar para que todo vaya bien.
  • Tras ir comprobando que nuestras oraciones son escuchadas (cuando vemos que vamos por el paso 5 de configuración), seguimos con toda la tensión del momento en cuanto a que esperamos el esperado final feliz en la configuración.
image image image
  • A pesar de todo, y como se menciona en el post solución, el asistente da un error al crear los datos de ejemplo…pero la instalación debería estar lista.
  • A partir de aquí, toca lanzar la Administración Central de SharePoint 2013 desde nuestro Windows Server 2012 RC…y tachán, aparece como se esperaba. Nuestras plegarias fueron escuchadas.
  • Las aplicaciones de servicio están provisionadas.
  • El sitio por defecto en el puerto 80 se ha creado sin problemas.
image image image

Published 18/7/2012 20:58 por Juan Carlos González Martín

Comparte este post: