.

una cortita - mi primer problema con Win 7

este post lo tenia en borrador hace uff... en si ya encontre mas bugs de win 7... pero aun asi me parece bueno...

si , ya se....  

hoy me anime a instalar en la particion principal de mi pc el win 7 y luego me puse a instalar el soft que uso regularmente........

tuve unos detallitos ... pero nada  comparado a cuando quise instalar el SP del Visual Studio 2008 ...

para empezar, yo uso las ediciones en español del VS - si ya se que muchos dicen que hay que usar en ingles, pero a mi me gusta en sp y lo uso -.

el Windows 7 trae por defecto el Framework 3.5 SP1 nativo, asi que a la hora de poner el SP 1 del VS 2008 - en spanish -  intenta instalar el paquete de idioma del fw 3.5 sp1, y alli es donde rebota.

Mirando el archivo de log y luego verificando a mano - descargue el archivo dotnetfx35langpack_x86es -  me sale un mensaje, de que ese paquete de idioma tengo que habilitarlo desde " agregar o quitar componentes" -algo que aun no existe en el windows 7, me refiero a agregar esa caracteristica desde agregar o quitar componentes -, supongo  que esta parte estara disponible mas adelante...- eso espero - , aunque no se como se hara con versiones como la home premium - donde estoy probando -, que no deja instalar paquetes de idioma, ojala y pronto decidan esto y lo habiliten, ya que en este momento no se puede instalar.... 

aun no decido si poner una virtual o volver al xp... jeje, pero no pondre el vs 2008 en ingles jeje -a las finales  tuve que ceder, por presiones laborales- .... cuestiones de orgullo :), ya envie el  reporte al team.. - y otros 4 mas - veremos que dicen en ms :)

fuera de eso, aun me gusta el win7...

salu2

Ddaz

Published 3/3/2009 1:23 por David Daniel Arroyo Zari "Ddaz"
Comparte este post:

Comentarios

# re: una cortita - mi primer problema con Win 7@ Tuesday, March 3, 2009 7:02 PM

Hola. Los paquetes de idiomas para de Windows (MUI y LISP) no tienen que ver con los paquetes de idiomas del .NET Framework, creo yo. Pero aparte de esto, comentar que yo tengo instalada la edición Ultimate de la Beta 1 de Win7 y, efectivamente, tengo el mismo problema.

Supongo que tiraré de momento por usar la edición en inglés del VS2008.

Salu2!.

by guacho

# re: una cortita - mi primer problema con Win 7@ Tuesday, March 3, 2009 8:00 PM

Ay mis estimados... y les recuerdo que no es bronca específica de Windows 7, creo yo. Porque a mí me sucedió una cosa horriblemente escabrosa en Windows Vista también por las cuestiones de los idiomas. Aunque allí creo el Framework no era el problema; también no hubo otra que formatear.

# re: una cortita - mi primer problema con Win 7@ Wednesday, March 4, 2009 7:06 AM

en este caso en especifico.. el languaje pack para el sp1 del framework si existe.... pero win 7 no deja instalarlo, en la epoca de win vista.. el lp no existia....   aqui el detalle es que el lp se instala desde "agregar o quitar componentes" xD... bueno el problema lo tengo abierto en connect.. luego de varios ida y vuelta.. quedo en "en un futuro habra" xD

salu2

ddaz

# re: una cortita - mi primer problema con Win 7@ Wednesday, March 4, 2009 7:09 AM

hey, pero no sera un "problema de diseño"??

jaja, vamos, que no creo que de momento se hayan tomado la molestia de probar combinaciones con herramientas en otros idiomas.

by Jersson

# re: una cortita - mi primer problema con Win 7@ Wednesday, March 4, 2009 7:17 AM

el problema es que hasta windows vista... esto de los LP eran free solo para la version ultimate... y de paga para las otras versiones...  y yo estaba probando especificamente la version "Home premium" - un beta especial que sacaron -  y la pregunta que les hice era de como se iba a hacer en "esa version de modo especifico", ya que era conciente que con la ultimate no hubiera habido problema..., hace poco me "chismeo" un compa que al parecer habran secciones de lp que seran free... pero ps eso ya luego de que habia escrito este post... nomas que no se pq no se publico en su tiempo xD

por eso mismo me iba por ese tipo de problema... en si se demoraron un par de semanas en saber responderme sobre "que pasaria para la home premium".. los del equipo de pruebas no tenian idea ...

salu2

DDaz

# re: una cortita - mi primer problema con Win 7@ Wednesday, March 4, 2009 2:00 PM

Buenas!

El mismo problema tuve yo al querer instalar el Visual Studio 2008 (Español) tanto en Windows Vista Ultimate, como en Windows 7, pero menos mal la solución en las dos siempre fue la misma, y hasta donde pude consultar se debe a un paquete de multilenguaje que tiene el Office, algo con InfoPatch...

Por si de pronto te sirve a ti o a alguien más la solución se las dejo, solo tienen que ir a Ejecutar y hacer  lo siguiente:

Windows XP: Inicio/Ejecutar y escribir:

msiexec /x {30120000-0044-0C0A-0000-0000000FF1CE} (Es recomendable a veces desinstalar primero todos los Net Frameworks porque puede traer interferencias.

Windows Vista: Con la combinación de teclas WIN+R ó ir a Inicio/Todos los programas/Accesorios/Ejecutar y escribir:

msiexec /x {30120000-0044-0C0A-0000-0000000FF1CE}

Windows 7: El mismo procedimiento de Windows Vista, y escribir:

msiexec /x {30120000-0044-0C0A-0000-0000000FF1CE}

Después solo le dan aceptar, para que desinstale ese unico componente con el Visual Studio cerrado obviamente, y luego proceder a la instalación :D...

Espero que de pronto les pueda funcionar, o lo tengan en cuenta porque es un error muy común y se soluciona así cuando el problema es componentes web si no estoy mal que aparece en el VS.

Gracias y ojalá puedas solucionar el problema para no tener que volver a XP =D, yo recomiendo quedar en Vista :)

Saludos!

by Checho

# re: una cortita - mi primer problema con Win 7@ Wednesday, March 4, 2009 3:21 PM

Hola Checho :

una solucion parecida me envio al inicio el team de win 7, pero el problema no es que no instale el vs, ya que instala y funciona, lo que no deja es "instalar el sp1 del vs", en mi caso no tuve problema al instalar el vs 2008, aunque tengo entendido que otros si tuvieron problema.

# re: una cortita - mi primer problema con Win 7@ Wednesday, March 4, 2009 3:22 PM

.. lo que si es definitivo... es que no vuelvo a vista... eso si que no.. ya me canse de sufrir mucho, y de ver como mi lap con 2 gb deram se mueve como si tuviera 256mb   :d

salu2

Ddaz

# re: una cortita - mi primer problema con Win 7@ Thursday, March 5, 2009 4:45 AM

@Ddaz,

Bueno hasta donde tengo entendido o vi, el SP1 no se instala porque si no estoy mal sólo está disponible y aceptable para la versión en inglés del VS2008, yo también tuve el problema y hasta ahora no veo solución diferente a reinstalar el Visual Studio pero en inglés =/.. si depronto el Team te ayuda con la versión o algo para español, aquí taremos pendientes!

Sobre Windows Vista, ps lo he usado desde hace ya un año aproximadamente, yo empecé con 2GB de RAM :)..

En verdad, que hasta con 1GB trabaja bien, pienso que queda mucho todavía en Windows Vista, no creo que se muera así, yo te vuelvo a decir dale la oportunidad, al probarlo se podrá juzgar, en comportamiento... y ahora recién ayer salió oficialmente el RC para todo el público. Lo que significa mejoras en performance, estabilidad, compatibilidad de hardware, y con solución de problemas de conexión Wi-Fi y varias cosas más!.

Me despido diciendo Windows Vista aún da para mucho más! ;)

Saludos!

by Checho

# re: una cortita - mi primer problema con Win 7@ Thursday, March 5, 2009 6:15 AM

checho:

vista performance?? juat!, definitivamente no me parece asi, quiza por que uso el sql 2005  y 2008, y sus versiones en express unas 3 instancias del vs 2008, ademas del mysql... con xp trabajaba bien,  con vista lo veia todo en camara lenta.

en si el problema que dices fue al instalar, pero si e podido instalar el vs 2008 en espaniol en win 7... espero que salga en el otro build el paquete de idioma xD

salu2

Ddaz

# re: una cortita - mi primer problema con Win 7@ Thursday, March 5, 2009 4:12 PM

@Ddaz,

Pues tengo instalado el VS2008, con el lo de SQL no lo he trabajado todavía, pero igual se debe ver en distintos contextos para probar si rinde o no, por ejemplo yo personalmente no he tenido problemas en la parte de procesos al correr aplicaciones de gran peso como PS CS4, VS2008, máquina Virtual entre otros...

Hay que reonocer que la performance no es la misma ni la que trae XP ni la que se puede dar con W7, puesto que si se tuvo falla en Vista, con algunos proceso y sobre todo al principio con compatibilidad de dispositivos y demás por ser un kernel diferente, pero la mejor que se ve de RTM - SP1 y ahora SP2 es muy significativa, aunque de este último no puedo todavía decir ya que no he probado el trabajo con el VS2008, pero sé que el rendimiento y la velocidad de trabajo mejorará con esta actualización, deberías darle oportunidad y probar :P...

Personalmente, Windows Vista me trabaja y se me comporta mejor que teniendo XP, tal vez en velocidad no obviamente, pero en cuestión de mejoras gráficas, de compatibilidad, de seguridad, y a nivel empresarial en deployment el cambio es muy grande!

En lo del VS2008 para 7, ya lo instalé también el Español, me hace falta es ver si de pronto si hay posibilidad de instalarle el SP1, teniéndolo con este idioma...

Saludos!

by Checho

# re: una cortita - mi primer problema con Win 7@ Saturday, March 7, 2009 3:30 AM

hola checho :  jeje ya pareces comercial de MS xD

tuviste menos problemas de compatibilidad con windows vista??? pues supongo que no tuviste que manejar varios tipos de hw... por que por la chamba tuve contacto con una gran variedad de fierros y ps con vista nomas no...  sobre lo de nivel empresarial que me dices.... TU lo has usado? has echo los deployment?   o solo has visto la promo de ms... lo que tengo que reconocer de vista es que "se ve bonito"... pero nada mas,  se quedo en "bonito", aunque no como un mac os... pero de alli no le vi ninguna mejora... solo mas consumo...., logicamente otra situacion es win 7, consume menos recursos los cuales uso para poder trabajar, la msima configuracion que con win vista .. y la diferencia en performance es enooorme, logico tiene algunos errores - por que es beta- y esperemos que los arreglen para la rtm... en cambio vista nomas no.. lo probe con el sp1... y lo que puedo decir es que estuvo "menos malo" pero no bueno...

e revisado el comportamiento de vista en mas de 35 tipos diferentes de configuraciones de HW... y en mas de la mitad .. vista no respondia..., por algo ms tuvo que sacar el downgrade a xp..- y luego las giras promocionando a vista -  por el gran fracaso de vista...

Salu2

Ddaz

# re: una cortita - mi primer problema con Win 7@ Saturday, March 7, 2009 8:23 PM

Hola!

XD.. no es propaganda sino que me parece algo exagerado ver el Windows Vista como un fracaso, cuando de mi parte he visto taanto progreso de lo que hace que se liberó.

En cuanto a deployment si tuve la oportunidad de probar en Windows vista, aunque no a gran escala, pero las ventajas de costo, administración y manejo me pareció un factor muy bueno.

No te discuto, que haya tenido tantos problemas de compatibilidad, de velocidad, y de administración de recursos, y tampoco que obviamente has probado muchísimas más cosas que yo después de todo tuviste ya el privilegio de ser MVP, pero lo que trato como hacer ver es que en un contexto general, Vista ahora funciona, hablo del último tramo de tiempo desde el SP1 hasta aquí, en lo que he visto, la mayoría tal vez un 85% me atrevería a decir de problemas se han solventado, o continúan en ese proceso.

He tratado de usar, y de probar hasta donde mi alcance me da, y trato de no basarme en lo que diga MS hasta yo mismo probarlo, pero por eos mismo el asistir a eventos, online o presenciales, y ver en tiempo real todo ese tipo de cosas que se decían con Vista no daba, ahora es diferente.

Ya por último ps desde que lo uso he tratado como ta te diste cuenta de defenderlo XD, por qué? porque el usarlo, trabajar en distintos contextos, y probar distintas cosas dentro del sistema, me hizo ver que hoy por hoy puede y trabaja en muchos casos mejor el Vista que el XP, simplicidad, características, compatibilidad, y sigo con performance XD etc..

Igual como decimos en Colombia "Entre gustos no hay disgustos", para mi es un gran gusto tratar este tipo de temas con expertos, y te agradezco :) espero pueda hacerme entender el punto al que quiero llegar.

Saludos!

by Checho

# una cortita Instalar Expression Studio 2.0 en español en Win 7@ Sunday, March 8, 2009 7:25 PM

estaba intentando instalar el Expression Studio 2.0 en Win 7 .. y el autorun del instalador, me pidió

by El Ddaz