Volvemos a las andadas Error de asp.net El compilador falló con código de error 128

Hola de nuevo a todos, tras una temporada sin escribir por vacaciones, pereza y cambio de domicilio vuelvo a las andadas en mi blog para contaros experiencias que os puedan servir a otros en nuestro divertido trabajo diario. Aprovecho también para agradecer los ánimos de algunos lectores de mi blog que echaban de menos que les diera la lata con algún artículo interesante J para la comunidad. Y es que particularmente creo que es mejor hacer de Homo Sapiens que de Neanderthal como menciona David en su Blog.

 En esta ocasión, en medio de un hermoso SP (No , no hablo de un Stored Procedure sino de un hermoso Síndrome Post Vacacional! J) me encontré un error en una aplicación Web asp.net que me dejó algo extrañado pues mi aplicación Web funcionaba correctamente en asp.net 1.1 en servidores de desarrollo y producción pero no cuando la alojaba en un conocido ISP  Decía así al intentar cargar una página aspx :"el compilador falló con código de error 128”  Y al mostrar los errores del compilador detallados salia una línea muy larga que empezaba por: 

c:\windows\system32\inetsrv> "c:\windows\microsoft.net\framework\v1.1.4322
\vbc.exe" /t:library /utf8output /R:"c:\windows\microsoft.net\framework\v1.1.4322\temporary asp.net files\root\0c1c7a12\a8dd6495\assembly\dl2
\852a5f9e\0b42d1d6_a988c701\componentart.web.ui.dll" /R:"c:\windows\microsoft.net\framework\v1.1.4322\temporary asp.net files\root\0c1c7a12
\a8dd6495\assembly\dl2\483641e1\a9101cc6_2788c701
\busyboxdotnet.dll" /R:"c:\windows\assembly\gac\system.web.services\1.0.5000.0__b03f5f7f11d50a3a\system.web.services.dll" /R:"c:\windows\assembly\gac\system\1.0.5000.0__b77a5c561934e089
\system.dll" /R:"c:\windows\assembly\gac\system.web\1.0.5000.0__b03f5f7f11d50a3a\system.web.dll"  

  Aquí se ve como la compilación falla al intentar cargar y ejecutar los ensamblados de la Web y se produce cuando usamos un componente de terceros como por ejemplo Busyboxdotnet que se ejecuta en el proceso W3wp.exe 
  
Este error es un bug del framework 1.1 y 1.0 que se subsana con el SP1 de W2003 o bien como dice en el siguiente artículo de la KB de Microsoft con un par de métodos: http://support.microsoft.com/kb/919085/es 

Evidentemente le tuve que advertír al ISP que “Algo pasaba con Mary” (Su servidor IIS que alojaba mi aplicación Web) y lo subsanaron sin problema :-)

 

Published 18/9/2007 9:43 por Sergio Vazquez
Archivado en:
Comparte este post:

Comentarios

Wednesday, September 26, 2007 10:36 AM por Lourdes Rodriguez

# re: Volvemos a las andadas Error de asp.net El compilador falló con código de error 128

Hola:

He leido tu comentario acerca del error, y a mi me esta sucediendo lo mismo, con mi proveedor de Internet, y me han abierto una incidencia para mirarlo. Si no es mucha indiscrecion. Cual es tu proveedor ?

Saludos

Thursday, April 24, 2008 4:59 PM por Sergio Vazquez

# re: Volvemos a las andadas Error de asp.net El compilador falló con código de error 128

Lourdes, Es arsys y ya abrieron una incidencia con Microsoft, aplicaron el SP en los servidores y ya funciona!

mientras no habia SP tenia que migrar los sitios web a asp.net 2.0

Thursday, June 25, 2009 7:12 PM por Leonel Gonzalez

# re: Volvemos a las andadas Error de asp.net El compilador falló con código de error 128

Muchas gracias Sergio, la explicacion me funciono de maravilla...

Saludos