Configuración del icono ¡Nuevo! de SharePoint

Siempre que en alguna lista o librería de SharePoint se agrega algún registro o documento, aparece durante un periodo de tiempo un icono de ¡Nuevo! para advertir la existencia de este nuevo elemento.

clip_image002

Esta propiedad que esta activa por defecto en todas las instalaciones de SharePoint se puede programar para cambiar el icono, establecer los días de permanencia o directamente decir que no aparezca.

Cambiar el icono

Este icono de nuevo no es más que una imagen que esta en el directorio ‘..12templatelayouts<idioma>images’ del servidor y se denomina ‘new.gif’, por lo que directamente modificando este fichero o creando uno personalizado con el mismo nombre podemos dotar de otro aspecto a esta advertencia.

Modificar los días de permanencia

Para modificar los días de permanencia de este icono o directamente decir que no aparezca tenemos que configurarlo desde la línea de comandos por mediación comando ‘stsadm.exe’ y los siguientes parámetros:

stsadm.exe –o setproperty –propertyname <name> –propertyvalue <value> –url <url>

Ejemplo de configuración:
stsadm.exe –o setproperty –propertyname days-to-show-new-icon –propertyvalue 0 –url http://litwaredemo

Donde el valor del parámetro ‘propertyvalue’ especifica los días de permanencia, y con el valor 0 hacemos que no aparezca.

4 comentarios en “Configuración del icono ¡Nuevo! de SharePoint”

  1. Estoy buscando una solución (preferible si no tengo que entrar a códigos) al siguiente:
    – Tenemos un Panel de discusión, donde cada nueva discusión, como es lógico visualiza con la etiqueta ¡Nuevo!
    – Desde la portada, visualizamos este panel usando ‘WebPart Visor de Contenidos’.

    Aunque accediendo a página donde se ubica el panel sí visualiza ¡Nuevo! no lo hace en la visualización vía Visor de Contenidos.

    ¿Como podemos hacer que también en el Portal (colocado vía Visor de Contenidos), también visualice ¡Nuevo! ?

    Muchas gracias

  2. Estoy buscando una solución (preferible si no tengo que entrar a códigos) al siguiente:
    – Tenemos un Panel de discusión, donde cada nueva discusión, como es lógico visualiza con la etiqueta ¡Nuevo!
    – Desde la portada, visualizamos este panel usando ‘WebPart Visor de Contenidos’.

    Aunque accediendo a página donde se ubica el panel sí visualiza ¡Nuevo! no lo hace en la visualización vía Visor de Contenidos.

    ¿Como podemos hacer que también en el Portal (colocado vía Visor de Contenidos), también visualice ¡Nuevo! ?

    Muchas gracias

  3. Hola,

    Quisiera saber si es posible que el icono New! aparezca con el texto de otra columna que no sea la del título de la entrada de una lista.

    Por ejemplo, tengo una vista que sólo muestra la descripción de cada entrada, ¿es posible que muestre la etiqueta New! junto a esta información?

    Me estoy volviendo loca y no encuentro nada… :S

    Muchas gracias de antemano, y enhorabiena por el blog 😉

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *