VS 2008 para proyectos ASP.NET 2.0 y AJAX 1.0

Una de las nuevas características de vs 2008 es el soporte de multi-targeting. Nos permite usar VS 2008 para proyectos .NET 2.0, 3.0 y 3.5, sin tener que actualizar los proyectos que ya teníamos a la última versión del framework. (como el intelisense de JavaScript, debugging de JavaScript, edición de código, masterpages anidadas, y las nuevas mejoras en el editor web y css – todas ellas funcionan tanto en proyectos .net 2.0 y 3.5).

Multitargeting con ASP.NET AJAX 1.0

VS 2008 nos permite abrir y editar aplicaciones ASP.NET 2.0 con la versión externa de ASP.NET AJAX 1.0 que publicamos el años pasado. Este soporte funciona muy bien con estos proyectos, y podemos usar las mejoras de JavaScript y del diseñador web – mientras estamos trabajando con .NET 2.0 y ASP.NET A JAX 1.0.

Nuevos templates para proyectos ASP.NET AJAX 1.0 en VS 2008

VS 2008 no incluye un template para crear proyectos de ASP.NET 2.0 y AJAX 1.0. Justo antes de navidad publicamos una descarga con estos templates. Podéis descargarlos de aquí  ( nota: debéis tener instalado ASP.NET AJAX 1.0 para poder usarlos).

Una vez que tengáis instalados estos templates, los podréis usar desde File-> New Project, o File -> New Web Site en VS 2008:

Nueva aplicación web con ASP.NET AJAX 1.0:

Las aplicaciones creadas con estos templates no necesitan tener .NET 3.5 instalados en el servidor para que funcionesn – podemos copiarlas a cualquier servidor web con .NET 2.0 y ASP.NET AJAX 1.0.

Espero que sirva.

Scott.

Traducido por: Juan María Laó Ramos. Microsoft Student Partner

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *