Volvemos a las andadas Error de asp.net El compilador falló con código de error 128

Hola de nuevo a todos, tras una temporada sin escribir por vacaciones, pereza y cambio de domicilio vuelvo a las andadas en mi blog para contaros experiencias que os puedan servir a otros en nuestro divertido trabajo diario. Aprovecho también para agradecer los ánimos de algunos lectores de mi blog que echaban de menos que les diera la lata con algún artículo interesante J para la comunidad. Y es que particularmente creo que es mejor hacer de Homo Sapiens que de Neanderthal como menciona David en su Blog.

 En esta ocasión, en medio de un hermoso SP (No , no hablo de un Stored Procedure sino de un hermoso Síndrome Post Vacacional! J) me encontré un error en una aplicación Web asp.net que me dejó algo extrañado pues mi aplicación Web funcionaba correctamente en asp.net 1.1 en servidores de desarrollo y producción pero no cuando la alojaba en un conocido ISP  Decía así al intentar cargar una página aspx :“el compilador falló con código de error 128”  Y al mostrar los errores del compilador detallados salia una línea muy larga que empezaba por: 

c:windowssystem32inetsrv> “c:windowsmicrosoft.netframeworkv1.1.4322
vbc.exe” /t:library /utf8output /R:”c:windowsmicrosoft.netframeworkv1.1.4322temporary asp.net filesrootc1c7a12a8dd6495assemblydl2
852a5f9eb42d1d6_a988c701componentart.web.ui.dll” /R:”c:windowsmicrosoft.netframeworkv1.1.4322temporary asp.net filesrootc1c7a12
a8dd6495assemblydl2483641e1a9101cc6_2788c701
busyboxdotnet.dll” /R:”c:windowsassemblygacsystem.web.services1.0.5000.0__b03f5f7f11d50a3asystem.web.services.dll” /R:”c:windowsassemblygacsystem1.0.5000.0__b77a5c561934e089
system.dll” /R:”c:windowsassemblygacsystem.web1.0.5000.0__b03f5f7f11d50a3asystem.web.dll”  

  Aquí se ve como la compilación falla al intentar cargar y ejecutar los ensamblados de la Web y se produce cuando usamos un componente de terceros como por ejemplo Busyboxdotnet que se ejecuta en el proceso W3wp.exe 
  
Este error es un bug del framework 1.1 y 1.0 que se subsana con el SP1 de W2003 o bien como dice en el siguiente artículo de la KB de Microsoft con un par de métodos: http://support.microsoft.com/kb/919085/es 

Evidentemente le tuve que advertír al ISP que “Algo pasaba con Mary” (Su servidor IIS que alojaba mi aplicación Web) y lo subsanaron sin problema 🙂

 

3 comentarios en “Volvemos a las andadas Error de asp.net El compilador falló con código de error 128”

  1. Hola:

    He leido tu comentario acerca del error, y a mi me esta sucediendo lo mismo, con mi proveedor de Internet, y me han abierto una incidencia para mirarlo. Si no es mucha indiscrecion. Cual es tu proveedor ?

    Saludos

  2. Lourdes, Es arsys y ya abrieron una incidencia con Microsoft, aplicaron el SP en los servidores y ya funciona!

    mientras no habia SP tenia que migrar los sitios web a asp.net 2.0

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *