Pregunta … para el que guste Responder….Sobre Versiones del .Net Framework en un Servidor en Produccion

Esto mas que un post… es una pregunta…. por  cosas que pasaron hoy.. justo cuando hablaba con Ziquilla…., esta pregunta viene por el Lado de It


la pregunta es ….



“Esta bien que Instalemos todas las Versiones del .NetFramework en un SERVIDOR de Producción ?, por mas que solo necesitemos 1, o 2 versiones del FW corriendo?”


El por que del Si y del NO…, podría ser por cuestiones de Seguridad ( vulnerabilidades), Performance,  Estabilidad, etc….


Si alguien aun lee este post ( si … quizá no quede ni uno luego de lo que le paso al ultimo post) , agradecería pudieran darme sus opiniones, ya que intento hacer una encuesta… ( si ya se que siempre paro haciendo encuestas).


Todo Esto nació por que ella tenia un problema con el versionamiento de una app, la hizo con el Vs2008, pero el Servidor ( no un hosting.. un servidor.. )  no tenia instalado el FW 3.5 , pero a su vez no podía instalarlo, por que los dueños no querían…, así que tuvo que pasar un buen rato downgradeando una aplicación…, y todo eso me puso a pensar… ( si ya se .. me adorno… el Ddaz pensando.. que tal perjurio!! 🙂 ) .


 


Salu2


 


Ddaz

3 comentarios en “Pregunta … para el que guste Responder….Sobre Versiones del .Net Framework en un Servidor en Produccion”

  1. Mhhh… en mi empresa tenemos una problemática similar pero creo que se debe principalmente a la desinformación respecto a las incompatibilidades que existen entre los distintos frameworks y a los posibles problemas que pueden surgir al intentar hacer convivir las distintas versiones del framework en una misma máquina.
    Por ejemplo nuestra aplicación corre sobre el fw 2.0 pero en mi pc de desarrollo tengo instalado el fw 3.5 y la aplicación sigue funcionando perfectamente, el problema es cuando se menciona la posible migración al fw 3.5 en ambiente producción y los gerentes y administradores ponen el grito en el cielo porque según ellos es “casi seguro” que la aplicación en algún momento va a fallar. Al final no están dispuestos a asumir ningún riesgo y es precisamente porque no tengo como justificar el cambio de framework sin asegurar al 100% que todo va a seguir funcionando como siempre.

    Saludos desde Chile.

  2. Pues daré mi opinión personal al respecto,… no sé si ayudará pero bueno,… aquí van mis dos centavos de forma resumida. 🙂

    Yo siempre he defendido desde la primera versión de Microsoft .NET Framework, que conviene instalar todas las versiones de distribución de .NET Framework y sus correspondientes Service Packs.

    En el caso de Microsoft .NET Framework 2.0, 3.0 y 3.5, comparten el mismo CLR (CLR 2.0) y reúne una serie de mejoras y nuevas clases y nombres de espacio.

    Adicionalmente, el sistema operativo salido en última hornada incluye la última versión de Microsoft .NET Framework, y el actualizador de Windows (Windows Update para los amigos) siempre trata de instalar la nueva versión de Microsoft .NET Framework y en su caso los últimos Service Packs.

    Con esto no quiero justificar que siempre se deba instalar todos los Microsoft .NET Framework, pero yo lo hago porque no hay problemas de compatibilidad, porque me aseguro que el posible fallo de una aplicación .NET no se debe a esos problemas, porque tampoco hay problemas con el famoso DLL Hell (http://es.wikipedia.org/wiki/DLL_Hell), porque Microsoft que yo sepa nunca hasta la fecha ha sacado nada respecto a incompatibilidad de Framework y aplicaciones, y porque me gusta en lo personal, tener instalado lo último una vez que verifico que es estable como le pasa ahora a Microsoft .NET Framework 3.5.

    Luego, los miedos, temores, desconocimientos, etc,… son normales, pero muchas veces infundados en la actualidad y casi siempre infundados en una experiencia pasada como podría ser el citado DLL Hell que todos hemos dufrido hace ya bastantes años.

  3. Pues creo que depende mucho la manera en como se le maneje, en este caso, al encargado de la empresa.

    Si se le maneja como una actualización, o mejora, creo que no existirá mucho problema en instalar todas las versiones del FW.

    Y como se dice en el comentario anterior, es poco probable la incompatibilidad entre versiones del FW.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *