[WEB] El curioso caso de en mi maquina funciona

¡En mi maquina funciona, y en otros tantos clientes también!

Ayer fue un día donde durante unas 4 horas largas casi 5 estuve ayudando a resolver una incidencia en la instalación de una aplicación web MVC4 que usa SQL SERVER 2008 R2 como motor de BD, que usa autenticación basada en formularios, etc., vaya algo bastante “común”.

Recibí un correo a primera hora de la mañana de un cliente que estaba teniendo problemas a la hora de realizar el login dentro de la aplicación. Él metía los datos de un usuario correcto, y al realizar la redirección a la página de inicio de la aplicación, nos encontrábamos un maravilloso:

image

Debido a distancia con el cliente, y a que no podían instalar ninguna herramienta para realizar escritorio remoto empezamos a realizar comprobaciones a través de skype:

– La conexión  con la BD era correcta, ya que un usuario erróneo, no llegaba a una pagina autorizada…

– Volvimos a registrar ASP.NET con el comand aspnet_regiis –i sin exito

– En el event viewer del servidor aparecía un problema que decía: Exception message: Server cannot set status after HTTP headers have been sent. Podeis ver mas info de este error en este post de SO. Yo tenía claro que no era un error en el código, debido a que la instalación con la misma guía de instalación se había realizado en diversos clientes ya, y yo ayer mismo, lo instale en mi IIS local, y en un equipo “limpio” sin tener este problema.

Después de ir revisando alternativas encontradas por internet no dábamos con la tecla con lo que en mi IIS local empecé a revisar la configuración de la aplicación, hasta que llegue a :

 

image

Le indique al cliente que fuera a la opción Autenticación de nuestra aplicación, y la opción de Autenticación mediante formularios estaba deshabilitada!!!!! En el instante en el que habilito dicha opción nuestra aplicación funciono.

 

Lo curioso de esto, es que por defecto está habitualmente se encuentra habilitada.

 

Espero que si os encontráis está situación podáis resolverlo con está solución!

 

Saludos!

Un comentario en “[WEB] El curioso caso de en mi maquina funciona”

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *